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Link

  • Overview
Libraries
  • Web
  • iOS
  • Android
  • React Native
  • Webview
Core Link flows
  • OAuth guide
  • Update mode
  • Preventing duplicate Items
  • Data Transparency Messaging migration
  • Link Token migration guide
  • Legacy public key integrations
  • Account Select v2 migration guide
Optimizing Link
  • Optimizing Link conversion
  • Measuring Link conversion
  • Pre-Link messaging
  • Customizing Link
  • Choosing when to initialize products
  • Returning user experience
  • Modular Link (UK/EU only)
Errors and troubleshooting
  • Troubleshooting
  • Handling an invalid Link Token
  • Institution status in Link
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Troubleshooting the Plaid Link Android SDK

Enabling Logs

The Link SDK logs information to LogCat at several points in the flow. Pass a LinkLogLevel value with the LinkTokenConfiguration to see the logs. The levels from least to most verbose: ERROR, WARN, INFO, DEBUG, VERBOSE.

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1val linkTokenConfiguration = linkTokenConfiguration {
2 token = "LINK_TOKEN_FROM_SERVER"
3 logLevel = if (BuildConfig.DEBUG) LinkLogLevel.VERBOSE else LinkLogLevel.ERROR
4}

Troubleshooting OAuth errors

A troubleshooting guide for common OAuth errors is below.

No redirect out of app

Link user experience
  • In Link, after clicking "Continue" on the OAuth screen, nothing happens.
Common causes
  • The user may be using an unsupported browser that is not compatible with Plaid's OAuth redirects, such as DuckDuckGo. For more details on which browsers are supported, see Supported browsers.
Troubleshooting steps

No redirect back to app

Link user experience
  • After completing OAuth in the browser or financial institution's app, the user is not redirected back to your app.
Common causes
  • The webpage is unable to locate an app on the device with a package id matching the one used to create the Link token.
Troubleshooting steps

The Play Store opened upon redirect

Link user experience
  • After completing OAuth in the browser or financial institution's app, the Google Play store opened.
Common causes
  • The webpage is unable to locate an app on the device with the package id matching the one used to create the Link token.
Troubleshooting steps

Link opens, then immediately closes upon redirect

Link user experience

After completing OAuth in the browser or financial institution's app, Link opens and then closes again.

Common causes
  • The webpage redirected back to the wrong application on the device causing Link to open and immediately close again as it gets data from a different session.
  • You may have both a test and a release version of your app installed on your device and used the wrong package name when creating the Link token.
Troubleshooting steps

Other common errors

To troubleshoot an error with an error code, use the error troubleshooting guide.

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